Page 1 of 2 12 LastLast
Results 1 to 15 of 21

Thread: New SATA HD Causes REALLY LONG Delay Expanding Folder in Windows Explorer

  1. #1
    Junior Member
    Join Date
    Jul 2004
    Posts
    18

    New SATA HD Causes REALLY LONG Delay Expanding Folders in Windows Explorer

    I conisider myself very technically competent, but this problem has me completely stumped. I can't find any info about it in a search of Google or of this forum. Here's my complete system info:

    Windows XP Home (with SP 1)
    Aspire X-Superalien case with the Aspire 500w PS
    MSI 865PE NEO2-FIS2R Mobo
    Intel P4 2.8C Northwood (800MHz FSB)
    2Gb Corsair TwinX 3200 RAM (4 X 512) (Page File turned off)
    MSI GeForceFX 5900XT Video Card
    Turtle Beach Santa Cruz Sound Card
    LiteOn 52X24X52 CDRW
    Hitachi 40X DVD ROM
    WD 80Gb EIDE HD
    IBM 30 Gb EIDE HD
    Miscrosoft Wireless Desktop Elite Mouse & KB
    DELL 2001FP Monitor

    And here's what I just changed yesterday that started the problem:

    I installed a new Hitachi 160Gb SATA HD, but only as additional storage, not as part of a RAID setup. I connected it to the onboard Promise SATA controller. It installed and formatted just fine and shows up correctly in Windows Explorer. I have already moved about 30Gb of files to it. The files transfered quickly as expected.

    But here's the problem: Each time I start the computer, then open Windows Explorer, there's a REALLY LONG delay expanding any of the folders for that new drive (and ONLY that drive - the other drives are not affected). The delay is always at least 30 seconds but it's usually closer to 2 minutes!! Once each folder has been expanded once, it will open quickly from then on, even if I close Windows Explorer then come back later. But if I reboot, I have the same delay expanding the folders again.

    Things I've tried or verified:
    1. Hitachi Drive Fitness Test veries the drive is OK.
    2. All BIOS settings are correct, and I've even experimented with some of them just to be sure.
    3. The computer is free of viruses or adware.
    4. There are no corrupt files on the new drive.
    5. All connections are correct and tight. I also tried another cable.
    6. The Promise driver is loaded and working.
    7. The drive has been defragged.
    8. I've turned off the "Indexing Service".
    9. DMA is enabled.
    10. I also used the ICH5 SATA controller and had the same problem.

    I hope one of you has a bright idea that I've missed.

    Thanks!
    Michael
    Last edited by MailManX; July 19th, 2004 at 19:58 PM.

  2. #2
    Junior Member wolfman's Avatar
    Join Date
    Jun 2004
    Location
    Florida
    Posts
    19
    This i dont believe will fix your problem, but i noticed your swap file has been turned off..You have alot of memory, but Windows does require the swap file at least alittle even with that much memory it will look to the swap file..Some programs as well will not function right without the swap file no matter how much memory you have..Will do some research on your problem though, as you have already tried everything i can think of at the moment...

  3. #3
    Junior Member
    Join Date
    Jul 2004
    Posts
    18
    Thanks for the reply Wolfman. You're right, the turning the page file back on didn't solve the problem. As for just windows in general, I've tried it both ways and it doesn't seem to make any difference. I've read pros and cons to having it off or on with a lot of RAM. It seems like a toss-up.

    Thank you very much for being willing to research this further. I'm usually very resourceful at figuring out computer issues, so it really ticks me off that I can't figure this one out.

    Michael

  4. #4
    Techzonez Governor Super Moderator Conan's Avatar
    Join Date
    Apr 2002
    Location
    Philippines
    Posts
    4,343
    Have you updated the BIOS of your motherboard? I know that early MSI motherboards had incompatibility issues with SATA drives.

  5. #5
    Junior Member
    Join Date
    Jul 2004
    Posts
    18
    Hi Conan,

    I was only one version out of date. But I just finished updating to the latest anyway. I had several of my fingers crossed, but it didn't solve the problem.

    Michael

  6. #6
    Techzonez Governor Super Moderator Conan's Avatar
    Join Date
    Apr 2002
    Location
    Philippines
    Posts
    4,343
    I would try a reformat of the C: drive then. Now if that doesn't work then the SATA drive might be faulty.

  7. #7
    Junior Member
    Join Date
    Jul 2004
    Posts
    18
    Before I reformat my C: drive, I think I'll try another option. Since I was able to make the problem follow the drive by moving it to another controller, I strongly suspect the drive. What I plan to do is buy an inexpensive SATA drive locally (ususally I buy on the internet) that I can test, then return. If it works fine, I'll know mine is bad. I'll let you know what I find out.

    Michael

  8. #8
    Techzonez Governor Super Moderator Conan's Avatar
    Join Date
    Apr 2002
    Location
    Philippines
    Posts
    4,343
    Good luck!

  9. #9
    Junior Member
    Join Date
    Jul 2004
    Posts
    18

    Updated Info:

    After three days of experimenting, benchmarking, tweaking and testing, I have verified that my new Hitachi 160Gb SATA HD is not faulty. But I did find out something unique that causes me to ask these questions:

    1. Is it a problem to have a mixture of FAT32 and NTFS formatted HD's in one computer?

    2. Does it cause file access performance problems to use all of the 160Gb HD as one partition (it's not the boot drive)?

    3. Why do folders with under 2Gb of data expand instantly when folders with over 2Gb are slow to expand, but only on the large new NTFS formatted HD?

    The final test I performed today was to buy and install an identical 160Gb HD in my computer. It exhibited the exact same problem as the first one. In Windows Explorer, expanding any folder on that drive containing more than 2Gb of files (including sub-folders) caused a delay. The bigger the folder, the longer the delay. For example, a folder with 5Gb of files took about 30 seconds to expand. A folder with 20Gb of files took about 2 minutes to expand. Sure, I could just make sure all the folders on that drive are under 2Gb. BUT WHY?? I don't have to do that with my older EIDE drives!! I didn't pay good money for a "fast" drive just to have it be slow to respond.

    Would making a few smaller partitions on this drive make a difference? Or, would reformatting my other drives in NTFS make this drive happy?

    My EIDE boot drive is 30 Gb and formatted as FAT32. It handles huge folders just fine.

    My EIDE second drive is 80Gb but has (3) equal partitions which are each formatted at FAT32. It, too, handles huge folders quickly.

    My new SATA third drive is all one partition and formatted, naturally, as NTFS. It hates large folders.

    The "Indexing Service" is turned off and "Find Fast" is not installed (heaven forbid!). So why the heck does the new drive have an issue with large folders?

    Thanks!
    Michael

  10. #10
    Techzonez Governor Super Moderator Conan's Avatar
    Join Date
    Apr 2002
    Location
    Philippines
    Posts
    4,343
    1. Is it a problem to have a mixture of FAT32 and NTFS formatted HD's in one computer?
    It shouldn't be any problem but why still stay with FAT 32 when you are using XP? I suggest a move to NTFS for all drives unless you are dual-booting with Windows 98/Me.

    2. Does it cause file access performance problems to use all of the 160Gb HD as one partition (it's not the boot drive)?
    No it shouldn't. I have 2 drives (both NTFS) look at my Sig for their details and they are both big and unpartitioned.

    3. Why do folders with under 2Gb of data expand instantly when folders with over 2Gb are slow to expand, but only on the large new NTFS formatted HD?
    This is the glitch in your system, I have folders which contain over 4 gig of data and there is no slowness in displaying my drive's folders.

    My suggestion is to convert all drives to NTFS (assuming you don't have a reason to stick with FAT32) and reformat the main drive and reinstall windows XP, though you could first try converting to NTFS before the reformat.
    Last edited by Conan; July 21st, 2004 at 12:41 PM.

  11. #11
    Old and Cranky Super Moderator rik's Avatar
    Join Date
    Aug 2003
    Location
    Watching Your every move...
    Posts
    4,688
    I agree that there "shouldn't" be an issue between Fat and NTFS causing the slowness problem. I also would convert all drives to NTFS. I am running a Hitachi 160 gb drive, but it is EIDE and has no slowness opening any folders. But it is formated NTFS. I also split the drive into 2 equal partitions when I installed it.

  12. #12
    Junior Member
    Join Date
    Jul 2004
    Posts
    18

    Narrowed Down!

    I've really narrowed it down! Turns out it's only folders full of JPG files that have the problem and the problem exists because of NTFS. After trying everything else I could think of, I converted my other drives to NTFS as a couple of you suggested. Then ALL my drives started experiencing the same issue. In a way, that was cool because I knew it was related specifically to NTFS. Then I hit on the idea of the JPG files being related to the problem.


    As a test, I created a HUGE FOLDER of non-jpg files. It had 14,393 files in a total of 1,048 folders with a total size of 9.6Gb. It expanded instantly. But an equally large folder of JPG files took over a minute to expand. It's as if something in my computer related to the NTFS format is trying to catalog or make thumbnails out of all the JPG's in a folder before it expands that folder. However, I can't really support the "thumbnail" theory because all of my folders are set to be viewed in the "details" mode. I don't use thumbnails, icons, or mini-icons.

    I figure there has to be a registry tweak or some other software setting that can easily resolve this. I just hope someone reads this that has experienced the problem before and remembers how to fix it!

  13. #13
    Techzonez Governor Super Moderator Conan's Avatar
    Join Date
    Apr 2002
    Location
    Philippines
    Posts
    4,343
    I have a folder dedicated to pictures totalling 2.64 gig in Thumbnail view and it expands immediately.

  14. #14
    Old and Cranky Super Moderator rik's Avatar
    Join Date
    Aug 2003
    Location
    Watching Your every move...
    Posts
    4,688
    Quote Originally Posted by Conan
    I have a folder dedicated to pictures totalling 2.64 gig in Thumbnail view and it expands immediately.

    Mines not as large as 2 gb but it does expand instantly upon opening.

  15. #15
    Phoar!! TZ Veteran zErO's Avatar
    Join Date
    Apr 2002
    Location
    Middle Earth
    Posts
    1,049
    Here are a few tips/solutions which may help improve you current problems relating to your new hard drive, although you should still take into account that it maybe a hardware related problem and not nessessarily software fault. Even if you have continually rechecked your system serveral times it may be as simple as replacing the cable between your SATA controller & the hard drive.

    1. Stop Windows from saving the thumbnail cache (THUMBS.DB)
    2. Improve NTFS Performance
    3. Temporary Decline in Performance Occurs When You Right-Click a File or Folder in Windows Explorer
    4. Suppress NTFS Volume Last Access Timestamp
    5. Recheck all hardware
    6. Speed up Detailed view in Explorer



    1. Stop Windows from saving the thumbnail cache (THUMBS.DB)

    Windows XP, by default, shows the thumbnails view of certain folders,
    Even if you choose Details (or some other view) as your default by going to Tools -> Folder Options -> View tab and click Apply to All Folders, Explorer may still revert back to the clumsy Thumbnails view. It does this for any folder in which it finds the THUMBS.DB file; naturally, if you delete this file, it won't happen again.


    The problem is that Windows seems to repeatedly recreate the THUMBS.DB file automatically. Here's how to stop this from happening:
    1. In Explorer, go to Tools -> Folder Options or open the Folder Options icon in the Control Panel.
    2. Choose the View tab, and turn off the Do not cache thumbnails option.
    3. Click Ok.
    You can also change this setting in the Registry:
    1. Open the Registry Editor (regedit.exe).
    2. Navigate to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced.
    3. Double-click the DisableThumbnailCache value, or go to Edit -> New -> DWORD value to create a new value by that name.
    4. Enter 1 for its value.
    5. Click Ok and close the Registry Editor when you're done; you'll have to log off and then log back on for this to take effect.
    2. Improve NTFS Performance

    1. Disable creation of short names. By default, NTFS generates the style of file name that consists of eight characters, followed by a period and a three-character extension for compatibility with MS-DOS and Microsoft Windows 3.x clients. If you are not supporting these types of clients, you can turn off this setting by changing the default value of the NtfsDisable8dot3NameCreation registry entry (in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Filesystem) to 1.

    2. Disable last access update. By default NTFS updates the date and time stamp of the last access on directories whenever it traverses the directory. For a large NTFS volume, this update process can slow performance. To disable automatic updating, change the value of the NtfsDisableLastAccessUpdate registry entry (in HKEY_LOCAL_MACHINE\SYSTEM\CurrentContolSet\Control\Filesystem) to 1. If the entry is not already present in the registry, add it before setting the value. (Add it as a REG_DWORD)

    3. Reserve appropriate space for the master file table. Add the NtfsMftZoneReservation entry to the registry as a REG_DWORD in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem. When you add this entry to the registry, the system reserves space on the volume for the master file table. Reserving space in this manner allows the master file table to grow optimally. If your NTFS volumes generally contain relatively few files that are typically large, set value of this registry entry to 1 (the default). Typically you can use a value of 2 or 3 for moderate numbers of files, and 4 (the maximum) if your volumes tend to contain a relatively large number of files. However, be sure to test any settings greater than 2 because these higher values cause the system to reserve a much larger portion of the disk for the master file table.



    3. Temporary Decline in Performance Occurs When You Right-Click a File or Folder in Windows Explorer

    Microsoft Knowledge Base Article - 819101

    http://support.microsoft.com/default.aspx?scid=kb;en-us;819101#appliesto

    SYMPTOMS

    In Windows Explorer, when you right-click a file or folder, you may experience any of the following behavior:
    • Any file-copy operation that is occurring at that time may appear to stop responding.
    • Network connection speed may significantly decrease.
    • All streaming input/output operations are degraded. For example, streaming audio over Windows Media Player becomes distorted.
    CAUSE

    When you right-click a file or folder in Windows Explorer, the CPU usage goes to 100 percent while the shortcut menu is displayed. CPU usage returns to the correct level when the shortcut menu is closed.
    WORKAROUND

    To work around this behavior, use either of the following methods. Method 1

    Turn off the transition effects for menus and ToolTips. To do this, follow these steps:
    1. Click Start, and then click Control Panel.
    2. In Control Panel, double-click Display, and then click the Appearance tab.
    3. On the Appearance tab, click Effects.
    4. In the Effects dialog box, click to clear the Use the following transition effect for menus and tooltips check box, and then click OK two times.
    Method 2

    Click the folder or file that you want (select it) before you right-click it to display the shortcut menu.
    STATUS

    Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.



    4. Last access time stamps

    XP automatically updates the date and time stamp with information about the last time you accessed a file. Not only does it mark the file, but it also updates the directory the file is located in as well as any directories above it. If you have a large hard drive with many subdirectories on it, this updating can slow down your system.

    To disable the updating, start the Registry Editor by selecting Run from the Start menu, typing regedit in the Open text box, and clicking OK. When the Registry Editor window opens, navigate through the left pane until you get to

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Filesystem

    In the right pane, look for the value named NtfsDisableLastAccessUpdate. If the value exists, it's probably set to 0. To change the value, double-click it. You'll then see the Edit DWORD Value screen. Enter 1 in the Value Data field and click OK.

    If the value doesn't exist, you'll need to add it. Select New | DWORD Value from the Edit menu. The new value will appear in the right pane, prompting you for a value name. Type NtfsDisableLastAccessUpdate and press [Enter]. Double-click the new value. You'll then see the Edit DWORD Value screen. Enter 1 in the Value Data field and click OK. When you're done, close Regedit. Your registry changes will be saved automatically.
    Reboot your workstation.



    5. Caching

    If your XP workstation has more than 256 MB of RAM, you might be able to increase hard drive access speeds by tweaking the amount of RAM cache that XP uses.
    Can be done by using third party software to enhance XP features

    http://techrepublic.com.com/5100-6270-5173646.html

    Easy Way to Adjust LargeSystemCache

    1. Right click My Computer
    2. Select Properties
    3. Click Advanced
    4. Choose Performance
    5. Click Advanced again
    6. Select either Programs or System Cache under Memory Usage.

    Programs = 0 for the registry tweak equilavent
    System Cache = 1 for the registry tweak equilavent

    The two different settings effect how the cache manager allocates free memory. If the Large Cache option is on, the manager marks all the free memory, which isn't being used by the system and/or applications, as freely available for disk caching. On the flip-side (with a small cache), the manager instead only sets aside 4MB of memory for disk caching in an attempt to accelerate the launch of applications. Or in a more technical approach, if enabled the system will favor system-cache working sets over process working sets (with a working set basically being the memory used by components of a process)



    6. Speed up Detailed view in Explorer

    If you like to view your files in Windows Explorer using the "Details" view here is a tweak to speed up the listing of file attributes:

    Viewing files in Windows Explorer using the "Details" mode shows various attributes associated with each file shown. Some of these must be retrieved from the individual files when you click on the directory for viewing. For a directory with numerous and relatively large files (such as a folder in which one stores media, eg: *.mp3's, *.avi's etc.) Windows Explorer lags as it reads through each one. Here's how to disable viewing of unwanted attributes and speed up file browsing:

    1. Open Windows Explorer
    2. Navigate to the folder which you wish to optimize.
    3. In "Details" mode right click the bar at the top which displays the names of the attribute columns.
    4. Uncheck any that are unwanted/unneeded.

    Explorer will apply your preferences immediately, and longs lists of unnecessary attributes will not be displayed.
    Likewise, one may choose to display any information which is regarded as needed, getting more out of Explorer.

    Goodluck
    Last edited by zErO; July 22nd, 2004 at 15:58 PM.
    R.I.P
    MSN Status: | Please Read The Forum Rules

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •