Results 1 to 5 of 5

Thread: CD-ROM red LED light always on...pls help

  1. #1
    Member
    Join Date
    Sep 2003
    Posts
    88

    CD-ROM red LED light always on...pls help

    i have a optorite 48x16x48 cd/rw drive. i have upgraded the driver, checked my connections, upgraded firmware, put in another computer. i run windows XP pro.

    the drive is recognized, but once i put a disk in, the red led goes on, and stays on. and when i try to access the disk, it says "please insert a disk". the red led never used to be on like this ever.

    any ideas? could the motor be shot?

    thanx

  2. #2
    Hardware Guru TZ Veteran shadow_warez's Avatar
    Join Date
    Jul 2002
    Location
    Edmonton,
    Posts
    852
    you could try upgrading the aspi drivers from www.etplanet.net and try using nero drive info to see if its even being reconized, properly,


    A Great Sig Done by a Great Artist,

  3. #3
    Old and Cranky Super Moderator rik's Avatar
    Join Date
    Aug 2003
    Location
    Watching Your every move...
    Posts
    4,688
    That may be a diagnostic indicator. I could find nothing on their website defining what the light means. I suggest contacting Optirite directly via email. support@optirite.com

  4. #4
    Titanium Member efc's Avatar
    Join Date
    Sep 2002
    Location
    North Central Arkansas
    Posts
    2,329
    Did you try another ribbon cable?
    Linux Mint Debian Edition

  5. #5
    Member
    Join Date
    Sep 2003
    Posts
    88
    yeah i havent tried the drive checking in nero yet...but i have used different cables and same thing. yeah i looked for error codes on the site also, notta.

    ill try the nero thing. thanks a lot for the suggestions everyone.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •