Results 1 to 12 of 12

Thread: Not Sure What Drivers To Install??

  1. #1
    Junior Member
    Join Date
    Aug 2004
    Posts
    37

    Not Sure What Drivers To Install??

    Hi,
    Got a ATI Radeon 9200, that much I know. Just installed SP2, a week ago, Every thing seems fine, just one crash with a 3rd party 3D screen-saver.
    I am not sure I am using the latest Driver for the ATI Radeon 9200.
    My PC iis only 10 months old. ATI website is confusing???, trying to download the rite Driver.

    Can someone please help me to get the latest Driver , compatible w/SP2

    thanks

  2. #2
    Techzonez Governor Super Moderator Conan's Avatar
    Join Date
    Apr 2002
    Location
    Philippines
    Posts
    4,343
    Quote Originally Posted by niteghost
    Can someone please help me to get the latest Driver , compatible w/SP2

    thanks
    Download this one:

    http://www2.ati.com/drivers/wxp-w2k-...5a-017633c.exe

  3. #3
    Junior Member
    Join Date
    Aug 2004
    Posts
    37
    Hi,
    Pardon my novice in XP, I have not install a Video Card Driver before. Can I roll it back , if it does not work out?? Or do I use System Restore.??

    Finally, found the Version # 6.14.10.6368

    I hope that D/L , you recommended is the newer one.

    How can I have instructions to install it successfully.

    Thank You
    Last edited by niteghost; September 26th, 2004 at 06:38 AM.

  4. #4
    Techzonez Governor Super Moderator Conan's Avatar
    Join Date
    Apr 2002
    Location
    Philippines
    Posts
    4,343
    Quote Originally Posted by niteghost

    How can I have instructions to install it successfully.

    Thank You
    http://www.ati.com/support/installat...tallwinxp.html

  5. #5
    Junior Member
    Join Date
    Aug 2004
    Posts
    37

    Unhappy Thanks

    Hi,

    I installed the Driver for the ATI Radeon 9200, successfully, amd I really don't like the looks of things. The characters appers "smudge" and my Icons appear so much smaller ( so I click on properties on the screen, and I try to adjust the Resolution, still don't like it )
    Anyway , Thanks for link and I had to "roll back" my drivers using System restore.
    sometimes , Newer DOES NOT mean better !

  6. #6
    Junior Member
    Join Date
    Nov 2004
    Posts
    4

    My Radeon 9200 doesn't work either

    I've been trying to play Half-Life 2, but I keep seeing through walls + some other glitches. So I too thought I might have to upgrade my driver. I tried the link posted on this thread, but my computer won't let me install it. It says I don't have the right hardware or software on my system. But I'm sure I have a Radeon 9200 card.

    Please help!


  7. #7
    Junior Member
    Join Date
    Nov 2004
    Posts
    4

    By the way

    By the way, the version number of my 9200 card is 6.14.10.6342

  8. #8
    Techzonez Governor Super Moderator Conan's Avatar
    Join Date
    Apr 2002
    Location
    Philippines
    Posts
    4,343
    You might also want to try drivers from here:

    http://www.omegadrivers.net/

  9. #9
    Junior Member
    Join Date
    Nov 2004
    Posts
    4

    Thanks, but...

    I really appreciate your efforts to help me but unfortunately, now that I tried installing the Omega driver, everything seems to be messed up! I have a widescreen laptop and now I can't even choose the resolution to keep things proportional any more.

    How do I get my old driver back?

    Thanks in advance!

  10. #10
    Techzonez Governor Super Moderator Conan's Avatar
    Join Date
    Apr 2002
    Location
    Philippines
    Posts
    4,343
    Try using System Restore.

  11. #11
    Junior Member
    Join Date
    Nov 2004
    Posts
    4

    good news

    Thanks for the tip!

    Before I was going to try System Restore though, I tried installing Omega a couple more times, just to be sure that it wasn't just a temporary glitch. And suddenly it worked! I've tried Half-Life 2 again, and so far it actually seems to work better.

    Thank you very much Conan!

  12. #12
    Techzonez Governor Super Moderator Conan's Avatar
    Join Date
    Apr 2002
    Location
    Philippines
    Posts
    4,343
    Quote Originally Posted by catharsis
    Thanks for the tip!

    Before I was going to try System Restore though, I tried installing Omega a couple more times, just to be sure that it wasn't just a temporary glitch. And suddenly it worked! I've tried Half-Life 2 again, and so far it actually seems to work better.

    Thank you very much Conan!
    Omega drivers are supposed to work better. Glad you got it solved.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •