Results 1 to 6 of 6

Thread: dxdiag/graphics card probs in xp

  1. #1
    Platinum+ Member
    Join Date
    Nov 2004
    Location
    India
    Posts
    686

    dxdiag/graphics card probs in xp

    I used win 2k pro previous to this. dxdiag.exe ran fine. displayed card details fine.
    Now in xp pro, I cant see any of the card details except for the "current display mode" details.
    The nVidia desktop manager is installed and my screen res is 800x600. i checked under device manager and it says that the VGA controller driver is not installed. My card is a Nvidia geforce4 MX 4000 series card with 128mb vram. What do I do? Should i reinstall my graphics driver??

    Also, How do I find out how many bits my graphics card runs at?

  2. #2
    Hardware guy Super Moderator FastGame's Avatar
    Join Date
    Apr 2002
    Location
    Blasters worm farm
    Posts
    3,416
    In Device manager does it list "Nvidia geforce4 MX 4000" under Display adapter ? if it does then right click and choose to un-install then reboot and see if it finds the driver. If that doesn't work then uninstall the Nvidia driver in Add & Remove and then reinstall the driver.
    Also, How do I find out how many bits my graphics card runs at?
    I take it you mean color ? should be in the normal place Desktop> Properties> Settings, you might have to get your driver problem fixed first ??? Your card will do 32bit color.

    If your talking "bits" the ram on the card runs at then it depends on what brand & model, 64bit/128bit.....

  3. #3
    Platinum+ Member
    Join Date
    Nov 2004
    Location
    India
    Posts
    686
    under device manager -> Display adapters it lists 'Video controller (VGA compatible) and NOT "Nvidia geforce4 MX 4000".
    I guess I'll reinstall my driver and keep u posted.
    thanks

  4. #4
    Platinum+ Member
    Join Date
    Nov 2004
    Location
    India
    Posts
    686

    Exclamation

    I reinstalled my display driver for my "Nvidia geforce4 MX 4000". The problem remains:

    Status Quo :
    1.Under device manager -> Display adapters it lists 'Video controller (VGA compatible) as a problem device.
    2.In contol panel, I see "nVidia Nmanager desktop manager". But when i try to open it nothing happens. Does that mean my display driver is improperly installed?
    3. This disply driver problem occurred after a technician reinstalled win XP Pro. (because I got an error saying that "windows did not find <path>/system/config Press 'r' to repair" . Windows would start in any mode, and I could not run system recovery and windows refused to repair itself - so I was forced to reinstall windows xp pro)
    4. I did NOT press uninstall driver under device manager before reinstalling my display driver. Do you think that is why the reinstall did not work?

    The only reason I havent uninstalled and reinstalled my display driver is because I have some imp work to do using the comp for the next few day, and i dont want anything to crash and I dont want to have to reinstall xp pro again)
    Last edited by tarun; January 11th, 2005 at 12:36 PM.

  5. #5
    Hardware guy Super Moderator FastGame's Avatar
    Join Date
    Apr 2002
    Location
    Blasters worm farm
    Posts
    3,416
    Is this video card AGP or PCI ?

    Un-install your "Video controller" in Device Manager then reboot into your MB bios and make sure the settings are correct for your video card then save & exit. When your PC boots up it'll reinstall the card and look for the driver....well thats what it should do ????

  6. #6
    Platinum+ Member
    Join Date
    Nov 2004
    Location
    India
    Posts
    686
    Under VGA Controller Properties, it says -
    Location : PCI bus 1, device 0, function 0
    How do i know for sure if its AGP or PCI ? Do i have to open up the cabinet and look at which slot its in? The system information on the card also points to it being PCI.

    About the BIOS - thanks, will...do

    ********************************************************
    Edit - I hav tried uninstalling the driver through device manager and then reinstalling the drivers with the CD provided by the manufacturer. I tried installing the driver from the CD, from Add New Hardware, and even after installing DirectX 9.0 . NONE of it has worked.
    When I installed the driver by going to control panel -> Add new hardware and selecting the driver location on a CD, windows says "an error occured during the installation" "the driver could not be installed" and "access denied'.

    dxdiag.exe shows that the default windows driver is installed. I am unable to install the driver provided by the manufacturer's CD. It worked fine with window 200 pro. Now, the driver will not install in windows xp pro.
    The only other alternative left is for me to download and install the drivers from the site.
    Last edited by tarun; January 13th, 2005 at 16:17 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •