Results 1 to 4 of 4

Thread: Enabling DMA for a LG CD-RW

  1. #1
    Platinum+ Member
    Join Date
    Nov 2004
    Location
    India
    Posts
    686

    Enabling DMA for a LG CD-RW

    How can I enable DMA for a LG CD-RW in XP? Nero prompts me to enable it everytime a CD is written/burnt.
    Will enabling DMA in anyway damage the CD-RW drive? Thats what it says HERE

    Its says also that CD-RWs run by default in PIO mode, so should I just leave the CD-RW be.... or enable DMA ?

  2. #2
    Hardware guy Super Moderator FastGame's Avatar
    Join Date
    Apr 2002
    Location
    Blasters worm farm
    Posts
    3,416
    No its not going to hurt the drive using DMA. If your drive can't handle DMA or errors then XP will reset it back to PIO mode. You'll be in for some long reading & burning if its PIO mode.

    If your drive is old it may not even use DMA....???

    To use UDMA go into your bios and make sure DMA is enabled. Go to Device Manager and click on IDE ATA/ATAPI Controllers, right click on Primary IDE channel> properties> Advanced Setting and in the pull down (transfer mode) select "DMA if available". Do the same thing on the secondary IDE channel and reboot.

  3. #3
    Titanium Member efc's Avatar
    Join Date
    Sep 2002
    Location
    North Central Arkansas
    Posts
    2,329
    1. Open Device Manager
    2. Double-click IDE ATA/ATAPI Controlers to display the list of controllers and channels.
    3. Right-click the icon for the channel to which the device is connected, select Properties and then click the Advanced Settings tab.
    4. In the Current Transfer Mode drop-down box, select DMA if Available if the current setting is "PIO Only".

    If the drop-down box already shows "DMA if available" but the current transfer mode is PIO, then user must toggle the settings.
    Last edited by efc; January 15th, 2005 at 19:16 PM.
    Linux Mint Debian Edition

  4. #4
    Platinum+ Member
    Join Date
    Nov 2004
    Location
    India
    Posts
    686
    THANKS a LOT guys! I see a noticeable difference in burn time.

    Guess I shoulda asked u guys instead of fooling around...

    In the BIOS it says -
    " PIO Mode : 4
    Ultra DMA Mode : 2 "
    So I guess UDMA is supported, and I dont get the 'enable DMA' message anymore.
    DMA is alive..... thanks again

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •