Results 1 to 5 of 5

Thread: Solved failed BIOS update on Gigabyte GA-K8NXP-SLI mobo

  1. #1
    Junior Member
    Join Date
    Aug 2005

    Thumbs up Solved failed BIOS update on Gigabyte GA-K8NXP-SLI mobo

    I managed to save myself from myself tonight, and I want to relate this story to you all because i found no help on the net, and I think if someone else Googles for this, it might help them too.

    I wanted to update my motherboard's BIOS to the current revision F9 ... in retrospect, for no good reason. I tried the Windows @BIOS utility first, and the one thing which sucked about it is that it doesn't tell you whether it is updating the "Main BIOS" or the "Backup BIOS", so I assumed it was doing the Main bios. It probably did, but I can not quite confirm this. It might also have just updated whichever was the "presently active" BIOS, which at the time was the "Main BIOS" (You can through an option set which one is used for booting on this motherboard.)

    After this update I had a problem that the machine would not hot-boot, not even from a BIOS menu. After any hot-boot, the computer would just sit with the CRTs receiving no signal and the monitors go blank and entering power-save mode.

    A Power-off-power-on cycle got the computer to boot up, but a "normal" reboot was just simply impossible. Note that I tried booting from both BIOSes and got the same result from both, but I may have actually buggered up this test, in fact I am about 99% sure taht I did bugger up this test. (After changing the active BIOS setting, I rebooted without first invoking the "Save Settings" function. It is not clear whether it saves the settings if you just boot.

    So I used the BIOS option to restore a backup I made earlier, and made sure both BIOSes had fresh copies of the image. Everything was then back to normal. But this was not enough for me, I had to try the BIOS utility (Quick Flash) to load the updated BIOS image. Foolish me.

    In any case, through some lucky strike I had this vague idea that switching back from Backup BIOS to Main BIOS would be easier than the other way round in case my BIOS update failed. I basically discarded my reason for thinking this, but in the same instant I thought to myself "Whatever ... I am not switching back to the Main BIOS, let me just update the Backup BIOS while the option is already highlighted". I don't know why I thought this. Maybe I had a feeling about what was to come.

    The image was loaded from disk succesfully and written to the backup BIOS without a hitch. When I rebooted I got the typical "stuck on black screen" problem I had earlier. I though I knew how to deal with this, and simply powered the system off. This did NOT help like it did the previous times. I tried various ways, unplugging the system completely, turning it off for 10 minutes, whatever. Nothing helped. I got into bed and could not sleep. Then I said to my wife "I can try to reset the BIOS with the motherboard jumper, or I can try to see whether it will boot from a diskette even though the screens remain black." She told me to go try it as she knew I could not sleep until I tried everything or got the problem solved.

    So I got my manual and looked up how to reset the BIOS. No instructions, just a mention what jumper it is. I know on some motherboards you need to close the jumber, then power on for a short while. On some boards you need to open the jumber and power-on. I did not want to risk this and scratched arround the internet a bit looking for hints. After reading some posts (none directly related to my motherboard) I decided to just close the jumper for a few minutes without any power. Amazingly, this solved the problem. My computer is now once more booting normally, from the Main BIOS!

    I believe that through a stroke of luck I updated the Backup Bios in stead of the Main BIOS. Right now the computer is once more running Bios revision F6. After resetting the BIOS, the dual-bios utility started booting from the primary bios once more.

    I still have to try a few more things. I want to try Revision 8 of the bios software. I want to try to boot from the Backup BIOS again not that I did reset the BIOS settings ... and I want to possibly try updating the BIOS via the DOS Command utility...

    Well, hope you enjoyed the story and maybe it is helpfull tom someone having problems somewhere!


  2. #2
    Precision Processor Super Moderator egghead's Avatar
    Join Date
    May 2002
    In Your Monitor
    thanks for the tip hartz

    and welcome to techzonez!

  3. #3
    Titanium Member efc's Avatar
    Join Date
    Sep 2002
    North Central Arkansas
    Thanks for your story. I have never had the courage to flash my bios. Your experience tells explains why. Glad you recovered.
    Linux Mint Debian Edition

  4. #4
    Super Moderator Super Moderator Big Booger's Avatar
    Join Date
    Apr 2002
    Excellent BIOS story. Thanks for sharing. Backup BIOSes have said quite a few. Ingenious idea really.

  5. #5
    Senior Member beelzebub's Avatar
    Join Date
    Aug 2004
    I am surprised there is no documentation about this. Have you tried using a diffrerent floppy disk, maybe the file you downloaded was corrupted.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts