Mozilla Firefox, Thunderbird and Suite DoS Exploits has recently posted two pieces of exploit code for the main three Mozilla products: Firefox, Thunderbird and the Mozilla Suite.

The first exploit, affecting Mozilla Firefox (versions 1.0.7 and below) and Mozilla Thunderbird (versions 1.0.6 and below), causes the program to stop responding and can be demonstrated by this line of HTML:


The second exploit causes the program to crash and apparently, Firefox (versions 1.0.7 and below) and the Mozilla Suite (versions 1.7.12 and below) are affected by this exploit:

<script language="JavaScript">
document.write('<link rel="stylesheet" href="http://">');

According to user reports, Mozilla Firefox 1.5 Beta 2 is not affected by any of the two exploits. The latest versions of Internet Explorer 6 and the Opera Browser do not seem no be affected either.

A workaround or patch is expected shortly.