Results 1 to 12 of 12

Thread: Mouse Initialization failure!

  1. #1
    Junior Member Peccavi's Avatar
    Join Date
    Oct 2005
    Location
    System32
    Posts
    29

    Mouse Initialization failure!

    Hey all,

    After changing my PS2 mouse to USB one I began receiving message at the very beginning of the start up says:

    Warning! PS2 Mouse Initialization failure. Press any key to continue.

    It was easy to press a key and I couldn't find solution also.
    But it made me sick.
    Any suggestions?

    Thanks.
    Rage Against Machine!

  2. #2
    Super Moderator Super Moderator Big Booger's Avatar
    Join Date
    Apr 2002
    Location
    JAPAN
    Posts
    10,961
    Check your BIOS setting. There might be some PS/2 support setting that you can disable that will correct this.

  3. #3
    Titanium Member efc's Avatar
    Join Date
    Sep 2002
    Location
    North Central Arkansas
    Posts
    2,326
    Assuming that you are using XP. Go to device manager and remove the mouse. When you reboot, it will find the usb mouse and install the proper driver.
    Linux Mint Debian Edition

  4. #4
    Junior Member Peccavi's Avatar
    Join Date
    Oct 2005
    Location
    System32
    Posts
    29
    Quote Originally Posted by Big Booger
    Check your BIOS setting. There might be some PS/2 support setting that you can disable that will correct this.
    I have been long searching for this option in BIOS. But couldn't find. I know it must be somewhere there but could you please be more particular.

    Quote Originally Posted by efc
    Assuming that you are using XP. Go to device manager...
    Yes I am using XP and did what you told. But it didn't help. Because it detects PS2 at the very beginning by POST. I need sth to do in BIOS .

    Thanks all.
    Last edited by Peccavi; November 12th, 2005 at 13:25 PM.
    Rage Against Machine!

  5. #5
    Super Moderator Super Moderator Big Booger's Avatar
    Join Date
    Apr 2002
    Location
    JAPAN
    Posts
    10,961
    [QUOTE=Peccavi]I have been long searching for this option in BIOS. But couldn't find. I know it must be somewhere there but could you please be more particular.[quote]

    It might be listed under something like the below:

    # Set Integrated Peripherals Settings: Enter the Integrated Peripherals menu and configure the following options:

    * PS/2 Mouse Enable: Set to "Auto" if your system has that option, otherwise enable it if using a PS/2 style mouse, disable otherwise.
    * USB Enable: Disable on most systems, unless using USB.


    However, without knowing your PC maker or BIOS type, it is nearly impossible for me to tell you specifics

  6. #6
    Titanium Member efc's Avatar
    Join Date
    Sep 2002
    Location
    North Central Arkansas
    Posts
    2,326
    The procedure that I was suggesting is not located in the BIOS.

    You will find the Device Manager by clicking Start. Then Right Click on My Computer. Now click Properties then choose the Hardware tab. Now click on the Device Manager button.

    To remove the mouse, click on the "+" to the left of the item, Mice and other pointing devices. Now highlight the mouse and remove it.

    Now you are ready to reboot the computer. XP should identify the usb mouse and install the proper driver.

    Good luck.
    Linux Mint Debian Edition

  7. #7
    Junior Member Peccavi's Avatar
    Join Date
    Oct 2005
    Location
    System32
    Posts
    29
    Efc, as I mentioned before that method didn't work. I am saying the same thing. Your suggestion is not related with BIOS , but I need sth from BIOS.
    If you know how to disable PS2 port detecting from BIOS plese tell.


    Big Booger, you are right. I send you my PC info as an attachment . Please have a look and see if you can help.

    I got into peripherals and USB was enabled. But I couldn't find anything resembling PS2 mouse port or sth like that.

    Thanks all.
    Attached Files Attached Files
    Last edited by Peccavi; November 12th, 2005 at 17:16 PM.
    Rage Against Machine!

  8. #8
    Titanium Member efc's Avatar
    Join Date
    Sep 2002
    Location
    North Central Arkansas
    Posts
    2,326
    See if this information might be helpful. LINK

    Also look at this. LINK2
    Last edited by efc; November 12th, 2005 at 18:07 PM.
    Linux Mint Debian Edition

  9. #9
    Junior Member Peccavi's Avatar
    Join Date
    Oct 2005
    Location
    System32
    Posts
    29
    Thanks efc,

    I tried what's told in those links. But unfortunately nothing.

    Big Booger, I found Integrated Peripheral and disabled Serial Port 2 in that. but still no change. I disabled a lot of things also and got no result.
    Rage Against Machine!

  10. #10
    Super Moderator Super Moderator Big Booger's Avatar
    Join Date
    Apr 2002
    Location
    JAPAN
    Posts
    10,961
    do you have USB to PS2 adapter? YOu could try that.

  11. #11
    Titanium Member efc's Avatar
    Join Date
    Sep 2002
    Location
    North Central Arkansas
    Posts
    2,326
    Quote Originally Posted by Big Booger
    do you have USB to PS2 adapter? YOu could try that.
    Yea, I was going to recommend that next.
    Linux Mint Debian Edition

  12. #12
    Junior Member Peccavi's Avatar
    Join Date
    Oct 2005
    Location
    System32
    Posts
    29
    Yeah, I think the next thing I will do is to buy it.

    Thanks all.
    Rage Against Machine!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •