Results 1 to 4 of 4

Thread: My emachines T2615 motherboard

  1. #1
    Junior Member
    Join Date
    Aug 2006
    Posts
    3

    Talking My emachines T2615 motherboard

    I've got an emachine T2615 that died. I replaced the powersupply and it powers up now. But the monitor won't display anything except a message like "no signal".
    I'd like to check the video card but it's integrated in the mobo. So I'm thinking I should just go ahead and replace it. Any ideas where I could find a replacement?
    Also, can I take the ram out of this one and put it in my other emachine a T1862 in an effort to retrieve my data?
    Thanks all for listening to me!
    Rattlebugs

  2. #2
    Titanium Member efc's Avatar
    Join Date
    Sep 2002
    Location
    North Central Arkansas
    Posts
    2,293
    I think if I were in your shoes I would consider purchasing a new MB. This one would be an inexpensive replacement that has built-in video and audio. It also has a separate AGP slot. Link

    Add this ram to put you back in business with faster memory. Link2

    Also look at some video card choices. Link3

  3. #3
    Super Moderator Super Moderator Big Booger's Avatar
    Join Date
    Apr 2002
    Location
    JAPAN
    Posts
    10,660

  4. #4
    Junior Member
    Join Date
    Aug 2006
    Posts
    3
    Thanks for the great advice -I am going ahead with the motherboard replacement. I can't tell you how much I appreciate your advice! You guys are great!!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •