Results 1 to 8 of 8

Thread: Oh, Oh, I installed XP twice. - [FIXED]

  1. #1
    Bronze Member
    Join Date
    Sep 2004
    Posts
    125

    Oh, Oh, I installed XP twice. - [FIXED]

    Due to a crash I had to recently reformat and re-install XP. However, I have two hard drives (C. D,) and initially I installed (in error, it was a late night) XP on Drive D.

    Later I installed XP again on drive C: (which was my preference), thinking I would just reformat drive D: and erase the XP OS there, leaving me with a fully functional clean install on C:.

    XP works fine on Drive C: and after having reformated Drive D: there is no trace of the XP OS on it.

    Now here's the issue,

    When I turn on my Computer, I get a black and white screen that says, I have XP installed twice and I am given an option of which OS to access. A 30 second timer automatically chooses drive C: if I don't choose it myself.

    Out of curiosity I picked drive D: once and it gave me an error message saying System32, file missing blah, blah. It is obvious that there is no XP on drive D: since the reformat of that drive, therefore, the error message.

    If the computer or I choose drive C:, then XP boots up fine, no problems.

    I'm inclined to just leave it alone, it seems like a harmless situation. However, if there is a quick fix to this, than please let me know.

    Thanks in advance,
    Halder,

  2. #2
    Junior Member
    Join Date
    Jun 2006
    Posts
    11

    Question

    Quote Originally Posted by Halder View Post
    Due to a crash I had to recently reformat and re-install XP. However, I have two hard drives (C. D,) and initially I installed (in error, it was a late night) XP on Drive D.

    Later I installed XP again on drive C: (which was my preference), thinking I would just reformat drive D: and erase the XP OS there, leaving me with a fully functional clean install on C:.

    XP works fine on Drive C: and after having reformated Drive D: there is no trace of the XP OS on it.

    Now here's the issue,

    When I turn on my Computer, I get a black and white screen that says, I have XP installed twice and I am given an option of which OS to access. A 30 second timer automatically chooses drive C: if I don't choose it myself.

    Out of curiosity I picked drive D: once and it gave me an error message saying System32, file missing blah, blah. It is obvious that there is no XP on drive D: since the reformat of that drive, therefore, the error message.

    If the computer or I choose drive C:, then XP boots up fine, no problems.

    I'm inclined to just leave it alone, it seems like a harmless situation. However, if there is a quick fix to this, than please let me know.

    Thanks in advance,
    Halder,


    Well ya could go to system properties in the control panel , then click on Advanced tab and got to third "settings" button. Inside you have the option of picking default Operating System.. also have the ability to edit the startup file manually.
    Good luck.

  3. #3
    Head Honcho Administrator Reverend's Avatar
    Join Date
    Apr 2002
    Location
    England
    Posts
    14,044
    Start > Run and type msconfig. Hit OK or Enter.

    On the BOOT.INI tab click the "Check All Boot Paths" button.

    When it finds the path related to the OS that you have removed it will ask whether you want to delete that entry from the boot.ini

    Click Yes and when you reboot the dual boot option will be removed.

    =========== Please Read The Forum Rules ===========

  4. #4
    Bronze Member
    Join Date
    Sep 2004
    Posts
    125

    thanks TryJay

    I took your advice and was able to reduce that 30 second countdown to 2 seconds. As to editing the start up file I have this in there now;

    [boot loader]
    timeout=10
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect /NoExecute=OptIn
    multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect

    Now, one of those two "multi(0)...." entries is the one that was deleted on D: but I am not sure which, is it the "NoExecute=OptIn" the first one or the second that just ends with "fastdetect",

    thanks again
    Halder

  5. #5
    Head Honcho Administrator Reverend's Avatar
    Join Date
    Apr 2002
    Location
    England
    Posts
    14,044
    Remove the bottom line:

    multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect

    =========== Please Read The Forum Rules ===========

  6. #6
    Super Moderator Super Moderator Big Booger's Avatar
    Join Date
    Apr 2002
    Location
    JAPAN
    Posts
    10,660

  7. #7
    Bronze Member
    Join Date
    Sep 2004
    Posts
    125
    Thanks Rev. Problem all fixed. Very much appreciated!

    Halder

  8. #8
    Junior Member
    Join Date
    Jun 2006
    Posts
    11
    Thanx fer the info, now I know how too!
    Thanx!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •