Results 1 to 4 of 4

Thread: IE pops up blank windows/browsers.

  1. #1
    Junior Member
    Join Date
    Sep 2002
    Posts
    1

    IE pops up blank windows/browsers.

    I switched over to using mozilla because IE broke on me somewhat.

    When a new window pops open it is always completely empty. I don't know what the deal is. I upgraded to IE6 hoping it would fix it but it didn't. Then I upgraded Win2k to win2k sp3 hoping that might fix it. Still no cigar.

    It works fine if I stay in the same window. But if a new window is to po up on a link or whatever then it comes up blank.

    Here is a screenshot.

    Example

    (note: I originally posted this question on neowin but that's gone now so I'm hoping you all can help)

    thanks

  2. #2
    Super Moderator Super Moderator Big Booger's Avatar
    Join Date
    Apr 2002
    Location
    JAPAN
    Posts
    10,961
    Two things come to mind here:
    A
    I want Internet Explorer's new window to open 'empty', without any content from other pages
    This is the only workaround I can think of to get what you want.

    Go to IE tools, internet options, general. Press "use blank" to set IE's home page to "about:blank: (a blank page). Click apply, ok. Now use the "home" button to go to your new home page.

    If you have active desktop, use your right mouse button to drag the icon for about:blank from your address bar to the Quicklaunch taskbar. Release and select "create shortcut". If you do not have active desktop, use your right mouse button to drag the icon from your addressbar to your desktop. Again, release and select "create shortcut".

    Now when you want a new blank window, click on the shortcut you've created.


    You have accidentally set your homepage to open a blank page. In that case simply do the reverse. Go to ie tools, internet options, general, then type an address in the blank of where you want it to open up.

    B
    IE6 opens blank (empty) windows
    Try disabling *all* other programmes, including virus scanners, to see if there is an improvement. If not, proceed as follows:

    You probably have a broken entry in file associations.

    Go to my computer, view/folder options/file types (or control panel, folder options depending on your operating system).

    Scroll down to the URL:Hypertext Transfer Protocols, click edit twice and make sure the following is in the application used to perform action box:

    "C:\PROGRAM FILES\INTERNET EXPLORER\iexplore.exe" -nohome

    The same applies for URL:Gopher

    DDE should be set to: "%1",,-1,0,,,,
    Application should say: IExplore
    DDE application not running should be blank
    Topic should be: WWW_OpenURL

    Mike Burgess MVP was kind enough to point out to me the other day that 'open in new window' is dependent on the following files, therefore you should ensure they are the correct version for your system, and correctly registered.

    Run the following commands from start/run. Run each line individually. After each run, you should see a short message stating the command was successful. The first command is the one most likely to work.

    regsvr32 Urlmon.dll

    regsvr32 Shdocvw.dll

    regsvr32 Shell32.dll (only applicable to Windows ME, Windows 2000 and XP - if using an earlier operating system, run regsvr32 shdoc401.dll)



    regsvr32 Oleaut32.dll
    regsvr32 Actxprxy.dll
    regsvr32 Mshtml.dll


    Some people have noted that replacing urlmon.dll or oleaut32.dll with the versions that came with their operating system has helped. I would not try this except as a last resort.

    Note: If the IE repair tool is available to you (control panel, add/remove programs, highlight IE, select add/remove) - running a repair will often fix the above associations automatically.

    Further note:

    I thought installing Mozilla 0.9.2 (which, may I say, is damned SLOW to start up) was quite a polite event, especially considering the fact that I didn't allow it to take over any defaults as part of the install.

    But still, I discovered that hyperlinks in emails weren't working properly anymore - IE was opening, but just to a blank window. No attempt to access the URL was made.

    Somehow or other, WWW_OpenURL disappeared out of 'topic' in the default open action for the URL:Hypertext Transfer protocols and Gopher - nothing else was out of whack - go figure :-/

    Some knowledge base articles addressing the blank window problem are:

    Browser Window Is Blank After You Install First Aid 98 [Q182038]
    http://support.microsoft.com/default...;EN-US;Q182038

    Current Web Page Is Blank After Opening an Outlook:// URL [Q257136]
    http://support.microsoft.com/default...;EN-US;Q257136

    That is pretty much self-explanatory.
    Please keep us updated and welcome to Techzonez.
    BB

  3. #3
    Head Honcho Administrator Reverend's Avatar
    Join Date
    Apr 2002
    Location
    England
    Posts
    13,503
    If Boogs suggestions fail.Go to Internet options,and on the advanced tab hit the Restore Defaults button.

    =========== Please Read The Forum Rules ===========

  4. #4
    Junior Member
    Join Date
    Sep 2002
    Posts
    2

    Thumbs up Its the regsvr32 on urlmon.dll

    I have had this problem at work on our PC's. The install of IE does not register the dll's properly. Usually the urlmon.dll is the one for blank new windows.
    jontmke

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •