Results 1 to 2 of 2

Thread: Disabling Windows Update Auto Reboot

  1. #1
    Super Moderator Super Moderator Big Booger's Avatar
    Join Date
    Apr 2002

    Lightbulb Disabling Windows Update Auto Reboot

    If you’re like me, your computer is always on, always connected to the Internet and the monitor is the only thing that gets turned off from time to time. This is great because you can leave a copy of FireFox open with 5-10 tabs of pages/articles that you want to read but don’t have the time to check out now. It’s also great for leaving temporary notes in notepad without cluttering up your desktop with saved files.

    All sorts of good reasons, but what happens when Windows Update installs a new update and forces your machine to restart without your permission? *poof* All of that is gone and you’re left staring at a login screen the next morning. Sure there are plugins available to save your session in FireFox, document recovery in Office, etc. but this is all a hassle and should be preventable, right? Luckily it is…

    For Windows XP Professional SP2 / Windows 2000/2003
    # Click the Start button, select Run…
    # Type in “gpedit.msc” (without the quotes)
    # Browse into Local Computer Policy->Computer Configuration->Administrative Templates->Windows Components->Windows Update
    # Right click on “No auto-restart for scheduled Automatic Updates installations” and select Properties
    # Change the radio button to select “Enabled” and hit Ok
    # There are several settings in this view that can be changed in regards to Windows Update. Each is well documented so poke around if you want to modify the behavior of Windows Update in another way.
    # Reboot your computer one last time for the setting to take place.

    For Windows XP Home Edition
    Warning, modifying your registry is dangerous. If you don’t know what you’re doing, get the computer kid down the street to do it
    # Click the Start button, select Run…
    # Type in “regedit” (without the quotes)
    # Browse to HKEY_LOCAL_MACHINE \Software\Policies \Microsoft\Windows \WindowsUpdate\AU
    # Right click and create a new DWORD Value named “NoAutoRebootWithLoggedOnUsers” (without the quotes)
    # Double-click this new value and set the Value data to 1
    # Or if you’re lazy, download this file and double-click it to add that value for you and skip the steps above.
    # Reboot your computer one last time for the setting to take effect.

  2. #2
    Join Date
    Sep 2005
    This is great, though windows update never forces you to reboot, it always give you an option to continue or reboot.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts