Results 1 to 3 of 3

Thread: DHCP Socket error

  1. #1
    Junior Member
    Join Date
    Sep 2002
    Location
    Ohio
    Posts
    1

    Exclamation DHCP Socket error

    I work for a Broadband ISP and have been coming across an error that nobody knows how to fix. It seems to happen mainly in Windows XP. The machine can no longer get an IP Address from the cable modem, and when the ipconfig /renew command is given, you get the following error. "An operation was attempted on something that is not a socket." (Error 10038) The only reference in the MS Knowledge Base is to McAfee Personal Firewall corrupting some network files. In our case only a few of the machines ever had this firewall installed.

    I have searched the web and tried all solutions suggested, reinstall TCP/IP, netsh, etc. But haven't had any luck.

    Any suggestions?

  2. #2
    Super Moderator Super Moderator Big Booger's Avatar
    Join Date
    Apr 2002
    Location
    JAPAN
    Posts
    10,941
    http://support.microsoft.com/default...;EN-US;Q319952

    Same error, different way to get it, the causes maybe the same..
    might be that the socket you are accessing is already being accessed..
    The socket is bound and listening on the loopback address 127.0.0.1.
    Just an idea.

    ANother idea,
    have you installed SP1? If so did it happen after or before? Also, have you updated all your drivers?
    just some basic issues to check.
    BB

    and lastly I found this:
    "Error writing to network. Cause:Socket operation on non socket (10038)"
    This is a Windows error message reported by the Winsock stack. It usually means the Winsock is not loaded correctly - ensure network services are in fact available (ask others if they are having problems) then try other Winsock compliant applications (eg WinQvt) to see if the same problem exists.
    Last edited by Big Booger; September 24th, 2002 at 15:48 PM.

  3. #3
    Precision Processor Super Moderator egghead's Avatar
    Join Date
    May 2002
    Location
    In Your Monitor
    Posts
    3,546
    hello:

    these are info pages to youe error code
    it might give you some idea's


    http://support.microsoft.com/default...;EN-US;Q319952

    http://www.basis.com/support/kb/kb00557.html

    error codes

    http://mindcritic.dyndns.org/crap/Mi...errorcodes.txt

    the problem could be in a replaced winsock.dll


    other things
    10038 WSAENOTSOCK Socket operation on non-socket. An operation was attempted on something that is not a socket. Either the socket handle parameter did not reference a valid socket, or for select, a member of an fd_set was not valid.


    the fix for nt is here

    http://support.microsoft.com/default...;en-us;Q185727

    something will be released for xp if the problem is rectified


    something interesting to read
    http://groups.google.com/groups?q=er...crnsc01&rnum=2


    i dont know what to say

    i post these links in the hope it may help you troubleshoot the problem

    there is not much on the net to help you


    someone here should be able to add more here

    egghead

    one more thing

    try the file signature verification tool in the system information wizard in the accesories / system tools/

    it should show you the names of ant modified files


    cheers
    Last edited by egghead; September 24th, 2002 at 16:07 PM.
    ------------------------------------------------------------



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •