Results 1 to 4 of 4

Thread: Can't delete folder on thumb drive

  1. #1
    Bronze Member
    Join Date
    Sep 2004
    Posts
    125

    Can't delete folder on thumb drive

    I have a thumb drive in which I back up some of my work files. Recently, I tried to delete a folder from the drive and I keep getting the same message over and over again, which is in a dialogue box,

    “Error Deleting File or Folder
    Cannot delete SO2: - Cannot find the specified file
    Make sure you specify the correct file and path name.”

    (Note: S02 is a file within the folder, the message refers to the file within the folder not the folder itself)

    Based on this error message it is as if the file/folder I am trying to delete is not there, or not seen by the computer (Windows XP), but is clearly there. I can rename it (and I changed the name to “Delete this”) and when I check “Properties” it shows as being 512K in size. I tried a virus scan on it (Kapersky) and nothing registered.

    I’ve deleted and created several folders on this thumb drive and never had a problem before.

    I’ve yanked out the thumb drive and restarted Windows XP and put the thumb drive back in and I get the same message.

    Simply, why does Windows tell me the file doesn’t exist and cannot delete it when it is there? And how do I get rid of it.

    Oh, the folder I am trying to delete contains some PDF files, but are not recognized as such, they have that generic windows icon.

    Thanks in advance
    Halder

  2. #2
    Techzonez Governor Super Moderator Conan's Avatar
    Join Date
    Apr 2002
    Location
    Philippines
    Posts
    4,229
    Have you tried reformatting it?

  3. #3
    Bronze Member
    Join Date
    Sep 2004
    Posts
    125
    No, I haven't done that, but I will. Thanks for the advice. I'll let you know how it turns out.
    thanks again, Conan.

  4. #4
    Bronze Member
    Join Date
    Sep 2004
    Posts
    125

    Fixed it

    I copied over all the files from the thumb drive that I wanted to keep onto a folder on mydesktop and left the bad file behind. Then I reformatted the thumdrive and "presto" file all gone.

    Thanks again Conan, I really appreciate your help.
    Halder

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •