Results 1 to 2 of 2

Thread: USB Ports Not Working - XP Home

  1. #1
    Bronze Member Island_Boy_77's Avatar
    Join Date
    Dec 2004
    New Zealand

    Angry USB Ports Not Working - XP Home

    Hi All
    I've come across this before, but not for a while - and now I can't remember how I fixed it!

    Here's the situtation:
    - Done a full, clean install on Toshiba laptop using it's own recovery DVD media: XP Home reloaded with all crapware + SP2
    - Installed SP3 + all the bits & pieces necessary for usual operation: during this whole time, no prob using USB Mouse in 1 of 3 USB ports
    - Got to the point of plugging in external USB 2.5" hdd (uses 2 ports - 1 for power, 1 for data) and got the dreaded "mass storage device not recognized" error
    - Plugged hdd into my Vista desktop - no probs
    - Did a restart with hdd plugged in - still no go
    - Tried plugging in USB 16GB stick - no go: oh great, it's that crappy "XP has sh*t it's USB subsystem" problem again
    - Deleted all USB devices out of Dev Manager & rebooted
    - On reboot, XP finds the main "Enhanced Host Controller" and the 3 "USB Universal Host Controllers", but I get 4 "unknown device"s instead of the USB Root Hubs that should be there.
    - Reinstalled Intel INF drivers from Toshiba driver folder & did reboot: no go
    - Followed these instructions:
    1. Delete following file: windows\inf\infcache.1

    2. Go to windows\inf folder and see if you have read/write permissions for following files:
    If not, open security settings for above files and add your username for read/write access.

    3. Open registry editor and:
    Delete following keys:
    HKLM\System\CurrentControlSet\Enum\USB\ <read all keys and delete all those saying USB Mass Storage Driver>

    Add following key:
    Add a new DWoRD Value and name it "DisableSelectiveSuspend". Give it value 1

    4. Make sure you have USBSTOR.SYS file in your windows\system32\drivers folder (It wasn't there in my case). Just Google using Usbstor.sys and you will find the file to download. Save it at above location.

    After doing above steps, restart your PC. Now Windows should recognize your mass storage and should do an autoplay.

    5. Some posts also mention that turning off the system and pulling out mains power supply and batteries for 30 mins is also helpful to resolve above problem.

    - It didn't work. I didn't do step 5 as that just sounds plain dumb, to say the least. Further, I haven't got anything plugged into the ports, so it's obviously some stupid software error - thanks Uncle Bill, I'll send you the invoice...
    - Next, I turned off the Legacy USB on the motherboard - no change
    - Next, I updated the BIOS - no change

    So now I'm in the middle of a Repair Install, which is not looking promising - despite plugging USB mouse in before boot, it's not working (altho trackpad is). It seems incredibly unlikely that the USB ports suddenly decided to fail, and even then the mouse was still working until I began dicking about in the Registry & deleting devices. I'm damned if I'll redo the 5 hours of work already done - unless the 2.5 hours I've already wasted fighting with this crap start heading towards 3, in which case I'll cut my losses & start from scratch.

    Thoughts? And don't say "go to 7" - that's not even a remote possibility.

  2. #2
    Head Honcho Administrator Reverend's Avatar
    Join Date
    Apr 2002
    Look for a key in the registry:


    If it is not there create it and set the DWORD value to 1. Reboot.

    =========== Please Read The Forum Rules ===========

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts