Results 1 to 3 of 3

Thread: FTP ACCESS hangs on LIST of Directories

  1. #1
    Super Moderator Super Moderator Big Booger's Avatar
    Join Date
    Apr 2002
    Location
    JAPAN
    Posts
    10,941

    FTP ACCESS hangs on LIST of Directories

    I am trying to access an FTP server, my server actually from work. I am behind a firewall and am using a program to emulate a proxy and tunnel through the firewall at work.

    I can ping the FTP, I can log in, but I cannot get the directories to list properly. IT just says listing, and then hangs up, waits for about 5 minutes then disconnects.

    I am using Bullet Proof Server 2.15

    and the latest build of FlashFXP to connect... I have flash working through a proxy in the advanced settings, set to 127.0.0.1, and port 1080, which allows it to connect to my FTP through Socks2HTTP. I have to access the server in passive mode because of the firewall..
    Any ideas?

    Here is the message that I get:
    Connecting to ***********.dyndns.org via Proxy
    Connected to Proxy 127.0.0.1 Port 1080
    220 BIGBOOGER's FTP
    331 Password required for ********* (username.
    PASS (hidden)
    230 User ********* (username) logged in.
    SYST
    215 UNIX Type: L8
    REST 100
    350 REST supported. Ready to resume at byte offset 100.
    REST 0
    350 REST supported. Ready to resume at byte offset 0.
    CWD /
    250 CWD command successful. "/" is current directory.
    PWD
    257 "/" is current directory.
    TYPE A
    200 Type set to A.
    PASV
    227 Entering Passive Mode (192,168,0,3,225,13).
    LIST
    Connection lost: ***********.dyndns.org

    does it every time.
    BB
    Last edited by Big Booger; February 3rd, 2003 at 23:12 PM.

  2. #2
    Head Honcho Administrator Reverend's Avatar
    Join Date
    Apr 2002
    Location
    England
    Posts
    14,044
    Have you tried it without the proxy,(0), and port 21.
    Also turn off passive mode as well.

    =========== Please Read The Forum Rules ===========

  3. #3
    Super Moderator Super Moderator Big Booger's Avatar
    Join Date
    Apr 2002
    Location
    JAPAN
    Posts
    10,941
    yep,it never connects unless I use the advanced options, proxy 5 with 127.0.0.1 and port 1080 with passive mode checked. Then I can connect, but the list fails...

    And I have tried connecting through a browser as well... doesn't work.
    BB

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •