Results 1 to 14 of 14

Thread: Removing Dual Boot Option.

  1. #1
    Member Muhammad Irfan's Avatar
    Join Date
    Aug 2002
    Location
    Pakistan
    Posts
    63

    Unhappy Removing Dual Boot Option.

    I installed Win Xp on 1 of my drives to dual boot my system with Win 98 which was already installed.Something went wrong & I had to format the drive containing Win XP.
    Now when I start my PC it asks me whether to start with Win 98 or XP even when XP is nt installed.If I choose XP it displayes an error message & the system is restarted.
    So please guide me that how can I get rid of that annoying option at startup asking me about the OS to start with.I knew how to do it in Win XP but it is nt possible for me to do it in 98.Now i,m running Win 98,how can i remove this.
    Muhammad Irfan

  2. #2
    Security Intelligence TZ Veteran cash_site's Avatar
    Join Date
    Jul 2002
    Location
    Software Paradise
    Posts
    3,852
    is it possible for you to reinstall XP? Even if you dont use it, it might be the easist solution?

    Im sure there are some free BootLoader programs you could use if all else fails.

    --- 0wN3D by 3gG ---

  3. #3
    My Name is.... TZ Veteran Stripe's Avatar
    Join Date
    Oct 2002
    Location
    live?
    Posts
    892
    You would need to modify the boot.ini in Windows.

    Here is a good article pertaining to it:

    Boot.ini Modification

    Watch out though. Make sure you know what you are doing because if you make a mistake, you may make the PC unbootable. I would recommend backing up the file before changing it.

    Let us know if you have any more questions or problems!

  4. #4
    Member Muhammad Irfan's Avatar
    Join Date
    Aug 2002
    Location
    Pakistan
    Posts
    63
    Thnx for the link.But my problem is still unsolved.
    The method mentioned by "cash_site" to reinstall Win XP & then do it ,is what I already know but i`ll use it as the final tool.
    You guys plz tell me how can i open the boot.ini file caze i`ve searched by the find tool & also tried to type boot.ini in the run menu but could nt get it.
    The article you mentioned contains information about Win 2000 & XP but nt 98.
    I also tried PQ Boot,a utility with Partition Magic but it only displays 1 OS (Win 98) in the start up choices.So i,m unable to remove that undesired XP option caze it is nt even visible.
    Muhammad Irfan

  5. #5
    My Name is.... TZ Veteran Stripe's Avatar
    Join Date
    Oct 2002
    Location
    live?
    Posts
    892
    Sorry about the confusion, I should've noticed you mentioned Windows 98.


    What you would need to do is open the msdos.sys and change the BOOTMULTI=1 to BOOTMULTI=0

    the 0 flag disables the Multiple boot option. Here is the Microsoft knowledgebase article on the msdos.sys file: MSDOS.SYS

    In order to see this file and edit it, you will need to do the following (this is also included at the bottom of the link above):

    On the View menu in My Computer or Windows Explorer, click Options or Folder Options.
    Click Show All Files on the Options tab, and then click OK.
    In the list of files, right-click the Msdos.sys file.
    On the File menu, click Properties.
    In the Attributes section on the General tab, click to clear both the Read-Only and Hidden check boxes, and then click OK.

    Then you can open the file in notepad and modify the contents.

  6. #6
    all bets are off... TZ Veteran SupaStar's Avatar
    Join Date
    Jul 2002
    Location
    Australia
    Posts
    1,680
    From MS:

    A setting of 0 disables the multi-boot option. (For example, with a setting of 0 you cannot boot your previous operating system.) A setting of 1 enables the F4 and F8 keys to boot your previous operating system.

    Wouldn't his previous OS be 98? Why does MS say this? I don't quite understand.

    Anyhow, Stripe's advice should lead you to the solution since you will no longer have a boot menu, which is what you asked to remove

  7. #7
    Member Muhammad Irfan's Avatar
    Join Date
    Aug 2002
    Location
    Pakistan
    Posts
    63
    Supastar ur confusion was right.I made the changes & inspite of changing the value from 1 to 0 nthing happened my way caze the boot options remained unchanged.
    Might be it is because Win 98 was my 1st OS & then I installed XP after it on another Drive.
    So as the "Previous" OS was 98 so the changes had nt the effect.
    Might be this was also be the reason with the PQ Boot & due to the same reason it only displayed only 1 OS.
    But my problem is still unsolved & I,m still waiting for ur assistance.
    Muhammad Irfan

  8. #8
    all bets are off... TZ Veteran SupaStar's Avatar
    Join Date
    Jul 2002
    Location
    Australia
    Posts
    1,680

    Hmmm...

    I've got two things for you to try...make sure you try number one before number two

    __________________
    1. Edit boot.ini

    Follow Stripe's initial advice and edit the boot.ini file. It appears that XP overwrites Win98's boot settings with it's own and this needs to be changed since you are no longer running XP.

    boot.ini is in c: root. It is a hidden system file, so to view it you will have to enable viewing of hidden/system files and also uncheck Hide protected operating system files. These options should be available from Folder Options in the Tools menu.

    Once you've opened boot.ini, remove the line multi(0)disk(1)rdisk(0)partition(1)\WINDOWS="Windows XP Professional" /fastdetect. (Perhaps make a backup of boot.ini first )

    Restart and see how you go.

    __________________
    2. Copy a new boot record to your hard disk

    If editing boot.ini didn't work, or you don't have that file, try this - and maybe you should backup your system first...just in case

    Boot your PC with a Win98 boot floppy or CD and when the dos prompt A:\ appears, type in sys C: and press ENTER. This will write new Win98 boot information to your C: which XP might have overwritten.

    Remove the boot disks and reboot.


    Good luck and let us know how you go

  9. #9
    Member Muhammad Irfan's Avatar
    Join Date
    Aug 2002
    Location
    Pakistan
    Posts
    63
    Supastar thnx a lot for ur assistance as I`ve finally got rid of that annoying dual boot option.
    Ur 1st advice of editing boot.ini file didn`t worked rather after deleting that I got a new option[Windows(default)] instead of Win XP.
    However when i tried method no. 2 it worked and I got my problem solved.
    Muhammad Irfan

  10. #10
    all bets are off... TZ Veteran SupaStar's Avatar
    Join Date
    Jul 2002
    Location
    Australia
    Posts
    1,680
    Great! Glad I could help

  11. #11
    Junior Member
    Join Date
    May 2006
    Posts
    1

    putting back the dual boot system

    i've just read about how to remove the dual boot...my problem was the reverse of that..
    i have the dual boot system...but an error occured on bootup...(ntldr is mising)
    so i make a copy of that..but when i put it back,,, another error occured
    (invalid boot.ini) and (hal.dll is missing)...
    and what a big mistake i've done was i reinstall the win98...after reinstalling(w/o formating) it boot on win98,,the problem was the option for the dual boot did;t show on boot....i failed to find boot.ini in win98,,,i'd look the msdos.sys but...i don't know how to edit that...below are what on msdos.sys...

    [option]
    bootGUI=1
    doublebuffer=1
    autoscan=1
    winver=4.10.10.2222
    ;
    ;the following lire are required for the compatibility with other programs.
    do no remove them (msdos.sys need to be >1024 bytes).
    ;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxa
    ;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxb
    ;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxc
    ;xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx up ....to s

    [Paths]windir=c:\windows
    winbootdir=c:\windows
    hostwinbootdrv=c

    anybody can help how to put back the option for dual boot..i'd look the d:drive (2nd partition where winxp was located) and it was on that...
    i think the only problem was the boot.ini ...please help me.....thanks in advance

  12. #12
    Old and Cranky Super Moderator rik's Avatar
    Join Date
    Aug 2003
    Location
    Watching Your every move...
    Posts
    4,688

  13. #13
    Junior Member
    Join Date
    Mar 2006
    Location
    In Texas.
    Posts
    15
    Boot with a Win98 startup disk, adn type in fdisk /mbr at the command prompt.
    Just remember love is life
    And hate is living death
    Treat your life for what it's worth
    And live for every breath

  14. #14
    Junior Member
    Join Date
    Jul 2006
    Posts
    1

    Talking Dancer Thanks

    Quote Originally Posted by SupaStar View Post
    I've got two things for you to try...make sure you try number one before number two

    __________________
    1. Edit boot.ini

    Follow Stripe's initial advice and edit the boot.ini file. It appears that XP overwrites Win98's boot settings with it's own and this needs to be changed since you are no longer running XP.

    boot.ini is in c: root. It is a hidden system file, so to view it you will have to enable viewing of hidden/system files and also uncheck Hide protected operating system files. These options should be available from Folder Options in the Tools menu.

    Once you've opened boot.ini, remove the line multi(0)disk(1)rdisk(0)partition(1)\WINDOWS="Windows XP Professional" /fastdetect. (Perhaps make a backup of boot.ini first )

    Restart and see how you go.

    __________________
    2. Copy a new boot record to your hard disk

    If editing boot.ini didn't work, or you don't have that file, try this - and maybe you should backup your system first...just in case

    Boot your PC with a Win98 boot floppy or CD and when the dos prompt A:\ appears, type in sys C: and press ENTER. This will write new Win98 boot information to your C: which XP might have overwritten.

    Remove the boot disks and reboot.


    Good luck and let us know how you go
    Absolutely Brilliant I had the same prob with ME after a dual boot with XP, The 2nd sugestion here sorted it after spending 2 days trying to fix it using fdisk and xfdisk and modifying ini files.

    Thanks
    Sponghead

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •