Results 1 to 4 of 4

Thread: DOS Junkies Unite

  1. #1
    Succeded in braking Windo TZ Veteran Dehcbad25's Avatar
    Join Date
    Apr 2002
    Location
    DE - USA
    Posts
    2,406

    DOS Junkies Unite

    I'm a bit of a DOS junkie myself, I'm more comfortable with it then I am with the pretty Windows GUI. I find I'm using the command prompt quite a bit while within Windows. Because I'm also quite lazy, I find that the auto complete function in the DOS prompt quite invaluable, however it's disabled by default. Luckily enabling it is quite easy, all we have to do is some registry editing.

    If you load up Regedit (Start, Run and type Regedit and then press the OK button) follow this path HKEY_LOCAL_MACHINE -> SOFTWARE -> Microsoft -> Command Processor. Right click on the CompleteChar DWORD value and change it's value to 9 (does not matter if you use Hexidecimal or Decimal).

    Reboot your computer and now when you're mucking around in the DOS prompt after you enter the initial DOS command (like CD, Copy, etc) simply hit the tab button to scroll through the list until hit what you're looking for. This works with Win2k as well as WinXP.
    I use it a lot at work, and it is pretty helpful

  2. #2
    Titanium Member efc's Avatar
    Join Date
    Sep 2002
    Location
    North Central Arkansas
    Posts
    2,329
    Good tip.
    Linux Mint Debian Edition

  3. #3
    Security Intelligence TZ Veteran cash_site's Avatar
    Join Date
    Jul 2002
    Location
    Software Paradise
    Posts
    3,852
    This is great!! I love it when I use UNIX at uni, i didnt know it worked on command line in XP, hey it was even enabled by default for me - mine was set to 40 for those longer words

    --- 0wN3D by 3gG ---

  4. #4
    Succeded in braking Windo TZ Veteran Dehcbad25's Avatar
    Join Date
    Apr 2002
    Location
    DE - USA
    Posts
    2,406
    YEp, it is a nice tip.
    I learn about it when I started playing around with Linux, then I liked that I could do that, and by custom I did it a couple of times in XP, and I saw it worked
    But it didn't work in all machines, so I looked for the way to enable it. I had enable this in almost every PC I had worked with in the last 8 months

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •