Page 1 of 3 123 LastLast
Results 1 to 15 of 31

Thread: Windows 2003 server needs over 20 min. to shut down?!

  1. #1
    Member
    Join Date
    May 2003
    Posts
    82

    Thumbs down Windows 2003 server needs over 20 min. to shut down?!

    Hi!

    I run Windows 2003 server. The server need over 20 min. to shut down.
    To restart need the server over 10 min..
    Is it normal?


    gicio

  2. #2
    Super Moderator Super Moderator Big Booger's Avatar
    Join Date
    Apr 2002
    Location
    JAPAN
    Posts
    10,941
    There are several registry settings that can be changed to decrease shutdown time.

    1. End services faster when shutting down. Saves alot of time.
    -Open regedit by typing "regedit" in the run box located on the start menu.
    -Browse to gHKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Controlh
    -Right click on the string value gWaitToKillServiceTimeouth
    -Select modify and change the value to g1000h

    2. Give windows the ability to automatically close non-responding apps.
    -Open regedit
    -Browse to gHKEY_CURRENT_USER\Control Panel\Desktoph
    -Right click on the string value gAutoEndTasksh
    -Select modify and change the value to g1h

    3. Reduce the timeout for windows to discover a non-responding application.
    -Open regedit
    -Browse to gHKEY_CURRENT_USER\Control Panel\Desktoph
    -Right click on the string value gHungAppTimeouth
    -Select modify and change the value to g1000h
    -Browse to gHKEY_USERS\.DEFAULT\Control Panel\Desktoph
    -Right click on the string value gHungAppTimeouth
    -Select modify and change the value to g1000h

    4. Reduce the delay to close non-responding applications and speed up the closing on apps at shutdown.
    -Open regedit
    -Browse to gHKEY_CURRENT_USER\Control Panel\Desktoph
    -Right click on the string value gWaitToKillAppTimeouth
    -Select modify and change the value to g1000h
    -Browse to gHKEY_USERS\.DEFAULT\Control Panel\Desktoph
    -Right click on the string value gWaitToKillAppTimeouth
    -Select modify and change the value to g1000h


    You could also try disabling the "Nvidia Driver Helper" service if using a nvidia card.
    - Go to the run box and type "services.msc"
    - Select "Nvidia driver helper"
    - Right click and press stop.
    - Go to properties of Nvidia Driver helper and change the startup type to "disabled"


    You "should" now see a marked improvement in shutdown speed.


    LEt me know how you get on.

  3. #3
    Techzonez Governor Super Moderator Conan's Avatar
    Join Date
    Apr 2002
    Location
    Philippines
    Posts
    4,343
    Did you apply any tweaks to Windows 2003?

  4. #4
    Member
    Join Date
    May 2003
    Posts
    82
    No I didn't.



    gicio

  5. #5
    all bets are off... TZ Veteran SupaStar's Avatar
    Join Date
    Jul 2002
    Location
    Australia
    Posts
    1,680
    10-20 mins is way too long. Has this been occuring since you first installed 2003 Server or is it something that has just started happening?

    What are your system specs?

  6. #6
    Member
    Join Date
    May 2003
    Posts
    82
    it's happend after instal:

    SQL server 2000 + Biztalk 2000 + Exchange 2003



    gicio

  7. #7
    all bets are off... TZ Veteran SupaStar's Avatar
    Join Date
    Jul 2002
    Location
    Australia
    Posts
    1,680
    What are your system's specifications?

  8. #8
    Member
    Join Date
    May 2003
    Posts
    82
    P 4 1.8 G
    512 MB RAM (DDR)



    gicio

  9. #9
    all bets are off... TZ Veteran SupaStar's Avatar
    Join Date
    Jul 2002
    Location
    Australia
    Posts
    1,680
    Have you tried any of Big Booger's suggestions above?

  10. #10
    Member
    Join Date
    May 2003
    Posts
    82
    not yet.
    no time

    I will do it tomorrow!

    let see....what hapend

    gicio

  11. #11
    Security Intelligence TZ Veteran cash_site's Avatar
    Join Date
    Jul 2002
    Location
    Software Paradise
    Posts
    3,852
    Have you tried any of Big Booger's suggestions above?
    I did, I remember doing these from Dehc's Tips I just made them a little more agressive as per BB. Should make for a zippyier comp

    --- 0wN3D by 3gG ---

  12. #12
    Super Moderator Super Moderator Big Booger's Avatar
    Join Date
    Apr 2002
    Location
    JAPAN
    Posts
    10,941
    one other thing,
    can you list all your applications that you have installed thus far?

    Thanks

  13. #13
    Member
    Join Date
    May 2003
    Posts
    82
    I tune my server now so Big Booger say...
    and now: 30 sec. to shut down!!!
    great!!


    is it possible to start the server faster?!?!?



    gicio

  14. #14
    Super Moderator Super Moderator Big Booger's Avatar
    Join Date
    Apr 2002
    Location
    JAPAN
    Posts
    10,941
    Enable Boot and Application Prefetching
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters. Change the value of "EnablePrefetcher" to 3


    Disable boot defrag, if enabled:

    Enable or disable boot defrag
    Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Dfrg\BootOptimizeFunction
    Select Enable from the list on the right.
    Right on it and select Modify.
    Change the value to Y to enable and N to disable.
    Reboot your computer.



    Remove unnecessary apps from loading at the start:

    click start
    click run
    type "msconfig" (without the quotes)

    Then click on the startup tab,
    then remove unnecessary items from that list.



    You can also try tweakXP for windows Server 2003:

    http://www.totalidea.de/frameset-tweakxp-net.htm

    How long does it take to boot?

  15. #15
    Member
    Join Date
    May 2003
    Posts
    82
    when I start tweakXP for windows Server 2003 I get this error message:

    'Required systemfile not found. Please re-install Tweak-XP .net!'

    after reinstall I get the same error message.

    whats wrong?

    gicio

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •