Results 1 to 2 of 2

Thread: Fix for broken images in Mozilla

  1. #1
    Head Honcho Administrator Reverend's Avatar
    Join Date
    Apr 2002
    Location
    England
    Posts
    14,044

    Fix for broken images in Mozilla

    Just thought i'd pass on this tip for Mozilla.

    I noticed today that the main TZ logo on the front page and forums wasn't being rendered correctly in Mozilla 1.5,(although Firebird 0.7 works perfectly). I think this is because Mozilla was still looking for the original logo after i changed it to the xmas one.

    Anyway,i managed to find a successful fix for the render problem.
    Thanks to Gunnars (unofficial mozilla help site)
    Sometimes images aren't displayed on their prospective pages, and when I right click on the image and go to "display image" it gives me a message with the following error message.
    - The image "[image name]" cannot be displayed because it contains errors. What can I do?
    This is a known bug that is being worked on. The image itself is fine, i.e. it contains no errors.
    The reason for this behavior appears to be the fact that Mozilla - depending on your Cache settings - requests the image twice. It only appears on websites that do not allow images to be linked to/called directly from outside of their pages. Since Mozilla does not send the referrer (i.e. web address of the page where the file is linked from) the second time it requests the image, the website sends an "access denied" page in HTML form where Mozilla is expecting an image, hence the error messsage (Mozilla tries to display an image when it receives an HTML page, so for the browser, the "image" contains an error).
    Solution: Change your cache settings to "Compare the page in the cache to the page on the network When the page is out of date". To do so, select "Edit" -> "Preferences" -> "Advanced" -> "Cache".
    Alan Wells pointed out another solution: Deleting the disk cache. To do that, select "Edit" -> "Preferences" -> "Advanced" -> "Cache" and Press the " Clear Cache" button. Pages should display fine after that.
    Last edited by Reverend; December 7th, 2003 at 11:09 AM.

    =========== Please Read The Forum Rules ===========

  2. #2
    Hardware guy Super Moderator FastGame's Avatar
    Join Date
    Apr 2002
    Location
    Blasters worm farm
    Posts
    3,416
    Thanks Rev! I had this same problem with Firebird 0.7 and now it works.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •