Page 1 of 5 12345 LastLast
Results 1 to 15 of 68

Thread: Windows XP "Cannot Delete AVI Files" FIX!

  1. #1
    Super Moderator Super Moderator Big Booger's Avatar
    Join Date
    Apr 2002
    Location
    JAPAN
    Posts
    10,941

    Windows XP "Cannot Delete AVI Files" FIX!

    Tired of getting "permission denied" errors when moving or deleting avi files in WinXP?

    WARNING - Use this file at your own risk.

    Executing this file will remove a registry key which makes explorer load shmedia.dll.

    Simply put, this removes the annoying "permission denied" errors when trying to move/copy/delete AVI files.

    To use this fix, right-click on the file and select install. Done.

    ed2k://|file|windows.xp.avi.delete.fix.zip|1078|31D283B58556BF37115FCF3A5C07BFBF|/

    You will need emule to download that file. Once downloaded you can then fix this annoyance that has plagued countless TZ users.

  2. #2
    Friendly Neighborhood Super Moderator phishhead's Avatar
    Join Date
    Apr 2002
    Location
    San Diego, Ca.
    Posts
    3,732
    cant you just del it at the cmd prompt thats how I get rid of those little boogers.



  3. #3
    Head Honcho Administrator Reverend's Avatar
    Join Date
    Apr 2002
    Location
    England
    Posts
    14,044
    Or you can rename the .avi extension and then delete it.

    =========== Please Read The Forum Rules ===========

  4. #4
    Super Moderator Super Moderator Big Booger's Avatar
    Join Date
    Apr 2002
    Location
    JAPAN
    Posts
    10,941
    with this fix it never happens again.

  5. #5
    Head Honcho Administrator Reverend's Avatar
    Join Date
    Apr 2002
    Location
    England
    Posts
    14,044
    Boogs,how big is that file ?? Is it small enough to attach?

    =========== Please Read The Forum Rules ===========

  6. #6
    all bets are off... TZ Veteran SupaStar's Avatar
    Join Date
    Jul 2002
    Location
    Australia
    Posts
    1,680
    All you have to do to fix this problem is delete the registry key: HKEY_LOCAL_MACHINESOFTWAREClassesCLSID{87D62D94-71B3-4b9a-9489-5FE6850DC73E}InProcServer32

    This prevents explorer from loading shmedia.dll which is used to provide you with properties of AVI (DivX) files. My understanding is that due to the way DivX files are encoded, XP has trouble collecting the properties and gives you the file in use message when you try to delete them.

  7. #7
    Super Moderator Super Moderator Big Booger's Avatar
    Join Date
    Apr 2002
    Location
    JAPAN
    Posts
    10,941
    Precisely SS. Thats exactly what that reg fix does.


    I have went ahead and added the fix to this thread as an attachment because some people do not have access to emule.
    Last edited by Big Booger; January 13th, 2004 at 22:22 PM.

  8. #8
    Security Intelligence TZ Veteran cash_site's Avatar
    Join Date
    Jul 2002
    Location
    Software Paradise
    Posts
    3,852
    nice find for the fix, traversing the directories in cmd was getting tiresome.

    --- 0wN3D by 3gG ---

  9. #9
    Junior Member
    Join Date
    Feb 2004
    Posts
    2

    Novice needs help!

    Quote Originally Posted by Big Booger
    Precisely SS. Thats exactly what that reg fix does.


    I have went ahead and added the fix to this thread as an attachment because some people do not have access to emule.
    As I am a novice, would you explain precisely how to use this attachment? I have been uselessly playing around with this attachment for 1/2 an hour, and have NOT gotten anywhere.

    I have not been able to see any place to "right" click and find an "install" selection! Wow! Frustrating!!

  10. #10
    Security Intelligence TZ Veteran cash_site's Avatar
    Join Date
    Jul 2002
    Location
    Software Paradise
    Posts
    3,852
    ok, first left-click the attachment, and save to your computer. Then extract the contents of the file to your computer. Then you can double-click the .reg file and say yes to merge with your registry. Thats all, easy

    --- 0wN3D by 3gG ---

  11. #11
    Super Moderator Super Moderator Big Booger's Avatar
    Join Date
    Apr 2002
    Location
    JAPAN
    Posts
    10,941
    The file I posted is a zip file. Zip files are used to reduce file sizes. If you are using windows Xp, just double click the file. Then in the right hand window, click extract.. If not, you'll need winzip.

    http://www.winzip.com

    Then, you should have a file xp-avifix.inf

    Now right click that .inf file. and click install or merge.

    That should work. It did for me. If not let me know.

    Cash beat me to it..

  12. #12
    Security Intelligence TZ Veteran cash_site's Avatar
    Join Date
    Jul 2002
    Location
    Software Paradise
    Posts
    3,852
    Sorry BB, must have been my quick ISP connection that posted quicker

    I think your answer is written a little more concisely. Trust no-one, except BB

    Has everyone used this? does it work flawlessly?

    --- 0wN3D by 3gG ---

  13. #13
    Junior Member
    Join Date
    Feb 2004
    Posts
    2
    Quote Originally Posted by Big Booger

    Then, you should have a file xp-avifix.inf

    Now right click that .inf file. and click install or merge.

    That should work. It did for me. If not let me know.
    Hi Big Booger!

    I have the "xp-avifix.inf" file. However, right clicking does not show any "install" or "merge" option! Wow!

    What am I doing wrong?

    Thanks,
    George

  14. #14
    Security Intelligence TZ Veteran cash_site's Avatar
    Join Date
    Jul 2002
    Location
    Software Paradise
    Posts
    3,852
    try double-left-clicking the file, hopefully it will install/merge by itself.

    If this doesnt work you may have to follow the suggestion provided by SupaStart earlier

    All you have to do to fix this problem is delete the registry key: HKEY_LOCAL_MACHINESOFTWAREClassesCLSID{87D62D94-71B3-4b9a-9489-5FE6850DC73E}InProcServer32
    Hope it works out for you. If this is too much - editing Registry can be dangerous - you can simply delete the avi file via the command prompt.

    good luck.

    --- 0wN3D by 3gG ---

  15. #15
    Super Moderator Super Moderator Big Booger's Avatar
    Join Date
    Apr 2002
    Location
    JAPAN
    Posts
    10,941
    Nice work Cash Daddy.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •