Results 1 to 9 of 9

Thread: hal.dll corrupt errors in my rig

  1. #1
    Precision Processor Super Moderator egghead's Avatar
    Join Date
    May 2002
    Location
    In Your Monitor
    Posts
    3,546

    hal.dll corrupt errors in my rig

    Hello!

    I have a p4p8x motherboard,
    http://www.asus.com/products/mb/sock...x/overview.htm

    I have the p4p800 bios installed and it works great!
    http://www.digital-daily.com/motherb...up/index08.htm

    with a cellery 2.4 ghz and 512 dual ddr memory.

    I have simply repair installed WindowsXP to allow myself the opportunity to continue some important work before I do a format and clean install.

    I keep getting a hal.dll corrupt message after a few reboots. (usually after installing service pack 1)

    Do you think my hd is going out to lunch? ( I record lots of HDTV with my sat card)

    Do you think the memory may be bad? its 3200

    The CPU is running at only 400mhz fsb.

    I am going to install a p4 2.6ghz 800ht shortly.

    Do you think windows is just playing with me because of the updated system?

    I updated my os many times before with different systems and this is the first time I am getting this error consistantly.

    Once every day or 2.

    Also sometimes if I keep rebooting it will finally load the os without error.....

    I also saw an error reading from disk message on a couple of boots

    It's an 80gig maxtor thats loaded and smartdrive says it is working fine.

    any suggestions?

    thanks
    egghead
    Last edited by egghead; January 27th, 2004 at 02:34 AM.
    ------------------------------------------------------------



  2. #2
    Titanium Member efc's Avatar
    Join Date
    Sep 2002
    Location
    North Central Arkansas
    Posts
    2,329
    Linux Mint Debian Edition

  3. #3
    Precision Processor Super Moderator egghead's Avatar
    Join Date
    May 2002
    Location
    In Your Monitor
    Posts
    3,546
    thanks efc!

    great work

    some tastey information there....

    so do you think it is memory that is corrupt or my compter or hard drive?

    I need to think this one through.

    An easy fix for this error is entering the recovery console and typing
    bootcfg /rebuild

    I will need to try this when i get home from work.

    My computer is dead with this error....

    I need to back up my computer and format and see if I still get these errors.

    This is a real nice motherboard for the price

    $112cdn p4p8x
    $96cdn celeron 2.4ghz
    $98cdn for 2 sticks of 256 dual ddr ram
    ------------------------------------------------------------



  4. #4
    Titanium Member efc's Avatar
    Join Date
    Sep 2002
    Location
    North Central Arkansas
    Posts
    2,329
    I'm not even going to guess about your HAL problem. I've never run into it before.

    When you fix it, please tell the rest of us how you did it.
    Linux Mint Debian Edition

  5. #5
    Techzonez Governor Super Moderator Conan's Avatar
    Join Date
    Apr 2002
    Location
    Philippines
    Posts
    4,343
    Is your memory voltage at 2.65-2.75? RAM timings by SPD?

  6. #6
    Precision Processor Super Moderator egghead's Avatar
    Join Date
    May 2002
    Location
    In Your Monitor
    Posts
    3,546
    hi

    just did a delete windows installation install so this should tell me if its my computer

    very frustrating
    i will check the memory conan and let you know
    ------------------------------------------------------------



  7. #7
    Techzonez Governor Super Moderator Conan's Avatar
    Join Date
    Apr 2002
    Location
    Philippines
    Posts
    4,343
    Quote Originally Posted by egghead
    hi

    just did a delete windows installation install so this should tell me if its my computer

    very frustrating
    i will check the memory conan and let you know
    If it's memory related you should run memtest86

  8. #8
    Head Honcho Administrator Reverend's Avatar
    Join Date
    Apr 2002
    Location
    England
    Posts
    14,044
    Windows could not start because the following file is missing or corrupt: Windows\System32\Hal.dll
    http://support.microsoft.com/default...&Product=winxp

    =========== Please Read The Forum Rules ===========

  9. #9
    Precision Processor Super Moderator egghead's Avatar
    Join Date
    May 2002
    Location
    In Your Monitor
    Posts
    3,546
    Thanks Reverend

    the bootcfg/rebuild

    and the /fastdetect for the last question allowed me to boot up fine.

    The memory is set on auto Conan.

    I did have errors installing xp deleteing current installation option but i think i will narrow it down tonight


    i will keep you updated.


    I think the HDTV recording could be killing my hard drive
    but i will try memtest
    tonihgt and a few other things

    thanks guys as always
    ------------------------------------------------------------



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •