Results 1 to 2 of 2

Thread: Unable to change files even though permissions enabled

  1. #1
    Junior Member
    Join Date
    Aug 2004

    Question Unable to change files even though permissions enabled

    I have a desktop PC and a laptop PC networked together over WiFi, and I'm experiencing a problem regarding the ability to rename/write/delete files on the OTHER machine (and sometimes reading them.) I'm also having a problem with sharing not propagating to some folders below.

    Both machines are running Windows XP Pro with SP1.

    Everything was working fine until an hour or so ago - all I can remember doing that may have messed something up, was enabling or disabling "Enable Simple File Sharing" in Folder Options on one of the computers - and then things started to go wrong.

    I am able to share folders between the two machines - in this particular instance I am sharing folders within both machine's "My Pictures" folders. But, when accessing these folders & their files from the OTHER machine (over the network) I am unable to rename or delete these files - even though I have enabled on a folder "Allow network users to change my files" (Simple File Sharing) or enabled Permissions For Everyone -> Full Control + Change + Read (when I use not Simple File Sharing.)

    Oddly, as well as not being able to delete or rename some files, some files I cannot even READ over the network - even though they read OK on the machine where they live.

    BTW, I can rename, delete and view files on the machine on which they reside with no problems.

    (1) What could be happening here, and how can I get back to normality? i.e. being able to read/delete/rename files on the other machine, when I allow it, and also having permissions propagate to folders underneath?

    (2) Is there anyway to reset things (permissions, shares etc.) to how they were when I first installed Windows XP?

    If you need any more info, or clarification let me know.

    Thanks in advance, Simon.

  2. #2
    Security Intelligence TZ Veteran cash_site's Avatar
    Join Date
    Jul 2002
    Software Paradise
    I think the Enable/Disable of SFS has caused your problems, and perhaps reset some settings.

    It is probably best for you to try and reset your sharing settings, perhaps even re-run the home networking connection wizard in the Network Settings Control panel.

    For simplicity, Simple File Sharing is adequate. Ensure the "Allow users change" box is checked, and also check to see if Authenticate as computer is set.

    Also, check your firwall settings if you have one installed ie ZA, Norton or even the default winxp firewall. Ensure that file sharing is enabled. Also, in your TCP settings for ethernet adapter, ensure File/Print option is installed and enabled.

    --- 0wN3D by 3gG ---

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts