Results 1 to 2 of 2

Thread: Why can't I disable DHCP in TCP/IP properties & do manual IP?

  1. #1
    Bronze Member Island_Boy_77's Avatar
    Join Date
    Dec 2004
    New Zealand

    Why can't I disable DHCP in TCP/IP properties & do manual IP?

    Hi all
    I've spent hours trolling the 'net for an answer to this. I haven't got more time to waste on it, so have opted for a repair install. However, I want to know the answer to this as I have to fix the prob on another PC.
    Using, I updated all the drivers on a friend's PC to the latest. Usually, driverguide recommendations are pretty good. However this time, they recommended a driver for the embedded nForce network controller on a Foxconn 6100 motherboard (has a GeForce 6100 +nForce 410 Chipset) that seemed more for Vista than XP (the driver was specifically listed as for Vista, but with compatibility back to 98SE). When I installed the driver and restarted, the LAN was NBG. Fine - so I installed a different compatible driver. Now the LAN worked. Or, it seemed to. Since I don't use DHCP, I tried using my normal manual assignment of IP / DNS in the normal manner. However, after clicking ok and closing the LAN Connections Properties box, the connection keeps dumping my settings and reverting to DHCP - very annoying! I've tried all manner of things as recommended in various posts, but nothing helps. I note that the culprit appears to be a #2 "WAN Miniport" device when I show invisible devices in the Device Manager. I can't delete the sod, so am picking that it is some how playing a part (even disabling it didn't help).

    Has anyone got any concrete suggestions as to how I fix this without a repair install? Oh, and I also tried updating the driver on the "offending" Miniport using an nvidia driver I trust by forcing it to take it (using the Have Disk option) - that gave me a BSOD.

    Help appreciated.

  2. #2
    Old and Cranky Super Moderator rik's Avatar
    Join Date
    Aug 2003
    Watching Your every move...
    Try booting into safe mode to delete that hidden device.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts