Results 1 to 3 of 3

Thread: USB 3.0 Hard drive issues

  1. #1
    Silver Member Linedawg's Avatar
    Join Date
    Sep 2005

    Question USB 3.0 Hard drive issues

    Hello everyone,
    I have a WD my passport 0740 external hard drive that has died. When I try to plug up the device it is recognized in the device manager but it will not initialize. When I try initialize the drive under disk management is get an I/O error with the device. I have tried multiple ports / workstations / laptops and operating systems with no luck. Below is a quick list of what I have tired.
    1. Change USB 3.0 cable out
    2. Used several operating systems (Windows 7 , Fedora 17, Windows XP, Windows Vista and Ubuntu Server)
    3. Tried the device in serial workstations / laptop.
    4. Tried Partition recovery software (unable to fix MBR, it is damaged but the software canít fix it)
    5. I have tried to change the USB drivers to system board driver and even make the device pick up as some other form of media storage (SD card, flash drive and etc)
    6. Attempted to mount the drive in Linux to see the device. Was not able to locate it.
    7. Also tied to freeze the hard driver (pure desperation) to see if I can make connection to the device.
    I wanted to see if anyone out that would have some advice on how to access this drive for a short period of time so that I can perform a data recovery. I have software to recover the data and formatting (if I have too) is not an issue. The software can dive down several partitions to recover data.

    The link below is an image of the system board that is on the hard drive. As you can see it is not your typical controller. No Sata, eSATA or IDE.

  2. #2
    Head Honcho Administrator Reverend's Avatar
    Join Date
    Apr 2002
    Have you tried running the Western Digital Data Lifeguard software?

    =========== Please Read The Forum Rules ===========

  3. #3
    Silver Member Linedawg's Avatar
    Join Date
    Sep 2005

    I ran that tool and still no luck. But thank you for the link to that application; it solved another unrelated problem I was working on. When I get the drive to recognize it tells me that it total capacity is 0.00GB.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts